Payomi Severe Degradation Affecting Certain Customers

Incident Report for Flowhub

Resolved

This incident has been resolved.
Posted Jun 09, 2025 - 06:00 MDT

Monitoring

Payomi has been actively restoring services for various clients, with only a few still needing services restored. We will continue monitoring the situation until all clients have been restored.
Posted Jun 05, 2025 - 12:11 MDT

Identified

We are currently working with the Payomi team to work through severe degradation of payment processing for certain customers.
Posted Jun 02, 2025 - 11:15 MDT
This incident affected: Payments Services (External) (Payomi Payment Processing).