Issues processing payments through EllaCash

Incident Report for Flowhub

Resolved

All issues have been resolved and payments are processing normally.
Posted Jun 18, 2023 - 13:25 MDT

Identified

The issue has been identified and service is beginning to recover. We expect to be back to operational in the next 2-3 hours.
Posted Jun 18, 2023 - 11:48 MDT

Investigating

Our payments processor is currently experiencing networking issues and is working quickly to restore service.
Posted Jun 18, 2023 - 04:05 MDT
This incident affected: Ellacash Payments.