Latency Under Investigation

Incident Report for Flowhub

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 13:01 MDT

Monitoring

A fix has been implemented, and service has been restored. We’re monitoring the system to ensure it remains stable.
Posted Aug 26, 2026 - 12:57 MDT

Update

We are continuing to work on a fix for this issue.
Posted Aug 26, 2026 - 12:55 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 26, 2026 - 12:45 MDT

Investigating

We are investigating an issue with latency in the Maui application. We’ll share an update as soon as we have more information.
Posted Aug 26, 2026 - 12:33 MDT
This incident affected: Maui POS.