Ellacash Terminal Issues
Incident Report for Flowhub
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 18:36 MDT
Monitoring
At this time, we believe all customers are up and operating again.
Posted Jul 22, 2024 - 16:29 MDT
Investigating
One of our partners that powers Flowhub Pay (EllaCash) is having issues with some customers. We are in touch with their team and they are working on a resolution, with an expectation of getting all customers back online in the next 3-4 hours. Please check our in-app messaging for more information.
Posted Jul 22, 2024 - 15:27 MDT
This incident affected: Ellacash Payments.