Partial Ecommerce Service Disruption

Incident Report for Flowhub

Resolved

This incident has been resolved.
Posted Feb 06, 2026 - 11:46 MST

Investigating

Flowhub Ecomm is unavailable for some customers due to a DNS-related issue. We have identified the root cause and are actively working to restore service for affected customers.
Posted Feb 06, 2026 - 09:05 MST
This incident affected: Flowhub Ecommerce.