Latency on Maui Application

Incident Report for Flowhub

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 18:36 MDT

Update

The latency issue affecting some users has been resolved and our team has confirmed performance is back to normal. Thank you for your patience today. A post-incident summary will follow.
Posted Apr 20, 2026 - 18:35 MDT

Monitoring

Some users may still experience slight lag on add to cart. Our team is actively monitoring and working to fully resolve it. Next update to follow.
Posted Apr 20, 2026 - 17:52 MDT

Investigating

We are continuing to investigate performance latency for some users.
Posted Apr 20, 2026 - 17:15 MDT

Monitoring

We have identified the cause of performance latency, and our team has been actively monitoring.
Posted Apr 20, 2026 - 16:38 MDT

Investigating

App performance is currently slower than usual for some users. We’re investigating and working to resolve it.
Posted Apr 20, 2026 - 16:27 MDT
This incident affected: Maui.