EllaCash terminal application issue
Incident Report for Flowhub
Resolved
All customers have been fully restored at this time.
Posted Apr 13, 2024 - 15:31 MDT
Identified
We're aware that some customers are still having issues with their terminals - EllaCash is aware and is resolving these one by one. We will close this incident when we believe all customer access is restored.
Posted Apr 12, 2024 - 11:16 MDT
This incident affected: Ellacash Payments.