EllaCash terminal application issue
Incident Report for Flowhub
Resolved
This incident has been resolved.
Posted Feb 13, 2024 - 10:47 MST
Monitoring
Ellacash has restored service to the terminals, and we believe everyone should be able to transact again. We're actively monitoring the issue to ensure everyone is able to process transactions successfully.
Posted Feb 13, 2024 - 09:27 MST
Investigating
We are aware of an issue is impacting point of banking terminals. We're working with Ellacash to repair the issue, and will update as soon as we have more information.
Posted Feb 13, 2024 - 09:25 MST
This incident affected: Ellacash Payments.