Google Cloud Services Outage Affecting Images and Analytics Reports

Incident Report for Flowhub

Resolved

This incident is resolved for all of our services.
Posted Jun 12, 2025 - 15:38 MDT

Monitoring

Google Cloud services are seeing a restore of normal performing services. Users may still experience some performance degradation with customer search and reporting. Issues can be tracked here: https://status.cloud.google.com
Posted Jun 12, 2025 - 15:07 MDT

Update

Customer search has now been added to the list of affected services, with slowdown for clients with large customer bases. Issues can be tracked here: https://status.cloud.google.com
Posted Jun 12, 2025 - 13:02 MDT

Identified

Google Cloud services are currently experiencing degradation that is affecting loading of reports and Flowhub's ability to pull product images for display within the app and any new image uploads for products and customer profiles. This may manifest itself sporadically until the issue is resolved by Google.
Posted Jun 12, 2025 - 12:42 MDT
This incident affected: Maui.