EllaCash terminal application issue
Incident Report for Flowhub
Resolved
EllaCash has restored service, and terminals should be functioning as normal at this point. If you continue to experience issues, please try restarting the terminals.
Posted Apr 12, 2024 - 10:28 MDT
Investigating
We are aware of an issue is impacting point of banking terminals. We're working with Ellacash to repair the issue, and will update as soon as we have more information.
Posted Apr 12, 2024 - 09:51 MDT
This incident affected: Ellacash Payments.