EllaCash terminal application issue
Incident Report for Flowhub
Resolved
This is now resolved, if you’re still experiencing issues please restart your terminal.
Posted Nov 01, 2023 - 18:03 MDT
Investigating
We are aware of an issue is impacting point of banking terminals. We're working with Ellacash to repair the issue, and will update as soon as we have more information.
Posted Nov 01, 2023 - 15:53 MDT
This incident affected: Ellacash Payments.