Payomi payment processing failures
Incident Report for Flowhub
Resolved
Payomi has resolved the issue. If you're still experiencing issues, please try restarting the terminals, update to the latest version of software by clicking the "globe" icon, and then log in and out of Maui. If you continue to experience issues please contact support.
Posted Oct 11, 2024 - 18:28 MDT
Investigating
Payomi is currently experiencing issues processing transactions, and is actively investigating the root cause. Other payment processors are unaffected. When we receive additional information from Payomi about the outage we will update this status page. If you are experiencing issues, please watch for updates here.
Posted Oct 11, 2024 - 17:15 MDT
This incident affected: Payomi Payment Processing.