The issue has been resolved - there is currently no impact to Maui. We will continue to monitor and ensure the issue doesn't reoccur.
Posted Sep 03, 2024 - 15:53 MDT
Monitoring
We have identified the issue - one of our metrics collection services experienced a major slowdown during the impacted times. We bypassed that metric collection service which restored performance of the system. We are actively investigating what caused the slowdown, and ensuring the system will automatically recover if this type of situation occurs again.
Posted Sep 03, 2024 - 12:04 MDT
Update
After a restart of some services, we're seeing all systems restored to normal operations. We are continuing to investigate root cause and monitoring.
Posted Sep 03, 2024 - 11:08 MDT
Investigating
We are currently seeing latency in the Maui application, with particular slowness in Cashier and Inventory. We're investigating the root cause and will continue updating with additional information.