EllaCash Processor Issue
Incident Report for Flowhub
Resolved
This incident has been resolved.
Posted Jan 31, 2025 - 15:09 MST
Monitoring
The technical issues being experienced by EllaCash's processor were resolved by 11:00 PM ET, and all systems are be back online. We are actively monitoring systems and will update with any additional information. You may resume using your EllaCash terminals.
Posted Jan 31, 2025 - 06:20 MST
Identified
EllaCash’s services are experiencing issues processing transactions for some customers. EllaCash is actively working on a resolution. If you are impacted, please watch our in-app messaging and status page for more information.
Posted Jan 30, 2025 - 14:01 MST
This incident affected: Ellacash Payments.