EllaCash terminal application issue
Incident Report for Flowhub
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 08:05 MST
Update
We are continuing to investigate this issue.
Posted Feb 03, 2023 - 08:05 MST
Investigating
We are aware of an issue affecting some payment terminals and working with our partners to get them back on line.
Posted Feb 02, 2023 - 18:28 MST
This incident affected: Payment Terminals.