Manage App: Specials are not listed in the manage app and new specials can not be created.
Incident Report for Flowhub
Resolved
This incident has been resolved.
Posted Sep 30, 2021 - 10:43 MDT
Investigating
We are investigating an issue that is causing created specials not to show in the Manage App. This issue is also preventing the creation of new specials.

All previously created specials are still populating in carts.

We will provide updates as soon as they are available.
Posted Sep 30, 2021 - 09:16 MDT
This incident affected: Manage.