EllaCash Terminal Connection Issues

Incident Report for Flowhub

Resolved

EllaCash has released a resolution for their connection issues with Maui. Please restart your terminals to ensure they receive the fix and let Product Support know if you are still experiencing this issue via our in-app chat or email help@flowhub.com
Posted Jul 08, 2025 - 12:31 MDT

Identified

Flowhub has discovered that BizPay (EllaCash) is currently experiencing intermittent connection issues with Maui. We are in communication with their team to determine when this issue can be resolved. Please continue to check with EllaCash support and monitor Flowhub's messaging through the status page and in-app banners for updates.
Posted Jul 08, 2025 - 12:07 MDT
This incident affected: Payments Services (External) (Ellacash Payments Processing).