Severe Degradation Causing Issues with Login and Various Operations

Incident Report for Flowhub

Postmortem

Status - Resolved

Summary - An outage occurred on Aug 1 from 9:55-10:34am MT due to expired TLS certificates associated with deprecated services. Although these services were no longer active, our NGINX ingress controller continued checking them during traffic routing for all Maui services. Despite all currently used services having valid certificates, the presence of the expired ones in the controller’s cache triggered routing issues. We resolved the issue by restarting the ingress controller to clear the stale certificates and this restart and recovery took approximately 25 minutes. All services were then fully restored.

Impact - 

All traffic was refused by the ingress controller from 9:55-10:34am MT causing a disruption in access to Flowhub Maui and several supported applications for most users.

Resolution - 

Restart of the Ingress controller to clear these cached expired certificates was the resolution.

Future Preventions - 

  • We’ve created a check for certificate validation in advance of certification expiry. Flowhub has heartbeat monitoring of its services, but those don’t flow through the traffic controller to do their checks.
  • We’ve added more FE Latency check alerts to customer support channels
Posted Aug 08, 2025 - 12:34 MDT

Resolved

All services have been confirmed to have returned to normal operating performance and availability.
Posted Aug 01, 2025 - 11:02 MDT

Monitoring

A fix has been deployed and all services should be restored.
Posted Aug 01, 2025 - 10:35 MDT

Update

The team is working through various potential resolution methods to restore services as quickly as possible.
Posted Aug 01, 2025 - 10:27 MDT

Update

We are continuing to investigate this issue.
Posted Aug 01, 2025 - 10:15 MDT

Investigating

We are currently investigating this issue with all engineers on hand.
Posted Aug 01, 2025 - 10:00 MDT
This incident affected: Maui, Greet, Stash, View, and API.